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现代测试与控制实验技术 

 

第一章 绪论（控制工程的基本概念、基本原理，测试技术的

基本概念、基本原理） 

1.1控制工程的基本概念 

1.2控制系统的基本原理 

1.2.1控制理论的简要历史 

1.2.2控制系统的一般概念 

1.2.3控制系统的基本方式 

1.2.4评价控制系统的基本指标 

1.3测试技术的基本概念 

1.4测试技术的基本原理 

1.4.1传感器技术概论 

1.4.2工程信号及其分析概论 

1.4.3测量数据处理及表述方法 

1.4.4测试系统的基本要求和传输特性 

第二章 测试与控制应用工具软件之一（Matlab） 

第一节    MATLAB概述 
1、MATLAB简介  2、MATLAB的工作界面  3、MATLAB的系统 
4、MATLAB应用举例 
第二节  数值运算 
1、数据类型（变量等）、2、矩阵运算  3、数组运算  4、多项式运算 
5、关系和逻辑运算   
6、数值分析（数据统计与分析、插值、拟合、微分、积分、傅里叶变换等） 
第三节  符号运算 
1、符号表达式（生成、化简、操作、转换、运算、符号与数值间的转换等） 
2、符号矩阵（生成、运算） 
3、符号微积分（符号极限、微分、积分、级数、积分变换等） 
4、符号方程的求解    5、符号函数（建立、运算、图形显示） 
第四节  程序设计 
1、M文件（分类、基本结构、变量等） 2、程序流程控制 
3、函数调用与参数传递（子函数、私有函数、参数传递） 
4、程序优化（P代码、性能优化、JIT和加速器） 
5、程序的调试（M文件中的常见错误、利用调试器调试、利用命令行调试） 
6、编程技巧 
第五节  MATLAB绘图 
1、二维图形的绘制 2、三维图形的绘制  3、特殊图形的绘制 
第六节  Simulink基础与应用 
1、Simulink库模块介绍  2、基本建模方法  3、建模举例  4、子系统 
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5、S函数的编写及应用 
第七节  MATLAB在控制工程中的应用 
1、控制系统的基本理论（模型、时域分析、频域分析） 
2、控制工具箱函数（模型的建立、变换、简化、实现、特性、方程求解、时域
响应、频域响应） 

3、控制系统分析（时域分析、频域分析、稳定性分析） 
4、控制系统设计（频率设计、PID控制设计） 

第三章 Matlab实例分析 

第一节 MATLAB总结 
第二节、MATLAB经验 
第三节  实例 
实例一： 进度条的使用 

实例二：求函数 545.46425)( 21
2
2

2
1212

2
1

4
1 +−+++−−= xxxxxxxxxXf 的极小值，

初始点为 T]2,2[− ，误差 ε不大于 0.01. 

实例四：时钟动画 
实例五： 运用 Simulink运行仿真 
实例六：用 FFT作谱分析 

实例 7：超前滞后校正网络（PID控制器）校正 

实例 8：S函数模块的创建和使用 

第四章 基于 Matlab的机械控制工程基础仿真实验 

实验一    Matlab软件学习实用 

实验二    开环、闭环系统时域特性分析 

实验三   开环、闭环系统频域特性分析 

实验三   控制系统频域特性分析 

一、 实验目的 

1、加深理解频率特性的概念，掌握系统频率特性的测试原理及方法。 

2、掌握频率特性的Nyquist图和Bode图的组成原理，熟悉典型环节的Nyquist图和

Bode图的特点及其绘制，了解一般系统的的Nyquist图和Bode图的特点和绘制。 

3、了解 MATLAB/SIMULINK，能够根据给出的传递函数运用 MATLAB 求出幅相频特性和

对数频率特性。 
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二、 实验设备 
序号 仪器设备名称 数量 

1 计算机 1 

  2         MATLAB软件               1 

  3 打印机              1 

三、 实验要求 
1、正确理解频率特性的概念，熟悉典型环节的频率特性。 

2、分析开环系统的频率特性，并绘制其开环 Nyquist图和 Bode图，求取剪切频率ω

c、相位交界频率ωg、相位裕度γ和幅值裕度 Kg、将实验结果与理论分析计算结果进行比较，

验证理论的正确性。 

3、分析单位反馈系统的频率特性，并绘制其 Nyquist图和 Bode图，求取谐振频率ω

r、谐振峰值 Mr，将实验结果与理论分析计算结果进行比较，验证理论的正确性。 

4、了解闭环频率特性与时域性能之间的关系。掌握开环增益 K 变化对频率特性的影

响，以及对 Bode图的幅频、相频的影响。 

5、掌握剪切频率ωc、相位交界频率ωg与系统的稳定性的关系及其规律、以及求取的

方法。 

6、了解相位裕度γ和幅值裕度 Kg与系统的相对稳定性的关系及其规律、以及求取的

方法。 

7、对系统的频率特性进行实验验证，掌握系统频率特性的测试原理及方法。 
8、根据开环系统的对数频率特性，确定系统组成环节的参数。 
9、实验数据、图形曲线、性能指标打印出来。 
10、理解掌握实验原理以及所列举的例子。 

四、 实验原理 
1、频率响应：线性控制系统对正弦输入的稳态响应。也就是说对于这种系统所给的

参考输入信号，只限于正弦函数，而其输出是考虑稳定状态，即当时间 ∞→t 时的情况。

频率特性记为  
)()(

)(
)()( ωω

ω
ω

ω jGjejG
jR
jYjG ∠==                                

2、幅频特性：正弦输出对正弦输入的幅值比
)(
)()(

ω
ω

ω
jR
jYjG =  

3、相频特性：正弦输出对正弦输入的相移
)(
)()(

ω
ω

ω
jR
jYjG ∠=∠  

     4、对数频率特性： 

Bode图——对数坐标图，又称 Bode图，它由对数幅频特性图和对数相频特性图组成。

对数幅频特性图纵坐标标度为 )(lg20 ωjG ，其中对数以 10为底均匀分度，采用单位是分

贝(db)；横坐标标度为 ωlg ，以对数分度绘制，标以ω，采用单位是弧度/秒(rad/s)。对

数相频特性图纵坐标为角度，均匀分度，采用单位为度，横坐标与第一张图完全相同。对数

相频特性图放在第一张之下，同时使横坐标的  上下一一对应，以便对比分析。 
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5、极坐标频率特性曲线（又称奈魁斯特曲线） 

它是在复平面上用一条曲线表示ω由 ∞→0 时的频率特性。即用矢量 )( ωjG 的端点

轨迹形成的图形。ω是参变量。在曲线的上的任意一点可以确定实频、虚频、幅频和相频
特性。 

6、利用 MATLAB对控制系统的进行频域特性分析 

（1）求取系统对数频率特性图（波特图）：bode() 

bode(num,den)：可绘制出以连续时间多项式传递函数表示的系统的波特图。 

（2）求取系统奈奎斯特图（幅相曲线图或极坐标图）：nyquist() 

nyquist(num,den)：可绘制出以连续时间多项式传递函数表示的系统的极坐标图。 

nyquist(num,den,w)：可利用指定的角频率矢量绘制出系统的极坐标图。 

（3）常用频域分析函数： 

margin：求幅值裕度和相角裕度及对应的转折频率。 

7、举例说明 

例 1：求典型二阶系统自然振荡频率固定，阻尼比变化时的波特图。 

%求典型二阶系统自然振荡频率固定，阻尼比变化时的波特图 

clear 

close all 

wn=6;% nω  

kosi=[0.1:0.1:1.0]; %ξ 值 

%在对数空间上生成从 10^(-1)到 10^1共 100个数据的横坐标 

w=logspace(-1,1,100); 

num=wn^2;%分子 

for kos=kosi%对应不同的ξ 值得 

   den=[1 2*kos*wn wn^2]; %分母 

%系统波特图相应的幅值 mag、相角 pha及角频率点 w1矢量 

   [mag,pha,w1]=bode(num,den,w); 

% 注意 mag的单位不是分贝，若需要分贝表示 

% 可以通过 20*log10(mag)进行转换 

   subplot(221); 

   hold on; 

   semilogx(w1,mag)%对应 w1的幅值 

% 注意在所绘制的图形窗口会发现 x轴并没有取对数分度 

   subplot(222) 

   hold on; 
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   semilogx(w,mag) %对应 w的幅值 

   grid on 

   subplot(223); 

   hold on; 

   semilogx(w1,pha) %对应 w1的相位 

   subplot(224) 

   hold on; 

   semilogx(w,pha) %对应 w的相位 

   grid on 

end 

subplot(221) 

grid on 

title('bode plot') 

xlabel('frequency(w)') 

ylabel('amplitude') 

text(6.2,5,'kosi=0.1') 

text(2,0.5,'kosi=1.0') 

subplot(223) 

grid on 

xlabel('frequency(w)') 

ylabel('phase deg') 

text(5,-20,'kosi=0.1') 

text(2,-85,'kosi=1.0') 

hold off 

例 2：已知系统的传递函数为：G(s)=K/(s^3+52s^2+100^s)，求当 K分别取 1300和 5200

时，系统的极坐标频率特性图 

clear 

close all 

clc 

k1=1300; 

k2=5200; 

w=8:1:80; %指定角频率矢量 

num1=k1; 

num2=k2; 

den=[1 52 100 0]; 
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figure(1) 

subplot(211) 

%可利用指定的角频率矢量 w绘制出系统的极坐标图 

nyquist(num1,den,w);  

subplot(212) 

pzmap(num1,den);%零极点分布图 

figure(2) 

subplot(211) 

nyquist(num2,den,w); 

subplot(212) 

%可得到系统频率特性函数的实部 re和虚部 im 

[rm,im]=nyquist(num2,den); 

%用 plot(re,im)绘制出对应 w从负无穷到零变化的部分 

plot(rm,im) 

xlabel('real') 

ylabel('image') 

title('w from 负无穷 to 零') 

figure(3) 

[numc,denc]=cloop(num2,den);%求系统的闭环传函 

subplot(211) 

step(numc,denc) %求闭环传函的阶跃响应 

subplot(212) 

[numc1,denc1]=cloop(num1,den); 

step(numc1,denc1) 

figure(4) 

subplot(211) 

bode(num1,den,w); 

subplot(212) 

bode(num2,den,w); 

五、 实验内容与步骤 
1、系统的 Bode图 

（1）在 MATLAB命令窗口中输入 shiyan3

后回车，得到下图所示界面。 

（2）单击 ，出现 Bode 响

应界面。 
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传递函数为
01

2
2

3
3

4
4

5
5

01
2

2
3

3
4

4
5

5)(
bSbSbSbSbSb
aSaSaSaSaSaSG

+++++
+++++

= ，其中 S^5、S^4、S^3、S^2、S^1、S^0

分别表示传递函数分子/分母的 5次方项、4次方项、3次方项、2次方项、1次方项、0次

方项（即常数项），S^5等各项前面的文本框代表各项的系数。 

 

 

（3）输入分子分母的系数： 

分子部分：在 S^1 前面的文本框 中输入 3，然后在 S^0 前面的文本框

中输入 4。 

分母部分：在 S^3前面的文本框 中输入 1，在 S^2前面的文本框 中

输入 3，在 S^1前面的文本框 中输入 5，然后在 S^0前面的文本框 中输入

7。 

（ 4 ） 输 入 分 子 与 分 母 系 数 后 ， 单 击

，即可得到系统的 Bode图。 

（5）单击 ，得到系统的谐振峰值、

谐振频率、带宽等性能指标。 

 

 

（6）在系统的 Bode 图

中，单击 即可打印图形。 

分子 

分母 
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2、系统的 Nyquist图 

（1）在“实验三   系统的频率响应”

界面中单击 ，得到下图所

示界面。 

 

（2）分别输入传递函数
1325

32)( 23 +++
+

=
SSS

SSG

的分子与分母各项的系数，然后单击 即可得到系统的 nyquist图。 

 

（3）单击 ，即可得到系统的零极点图。 
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（4）在系统的 nyquist图中，单击 即可打印图形。 

六、 实验报告要求 

1、必须列出理论计算结果。 

2、画出理论曲线并与实验曲线相比较，分析产生差异的原因。 

3、结合实验遇到的问题谈谈对实验的看法。 

4、必须把实验数据、图形曲线、性能指标打印出来。 

七、 思考题 
1、 单位开环增益变化时对频率特性有何影响？ 

1） 分别标注不同 K值Nyquist图上在ω=0时渐近线坐标值，以及曲线与负实轴的

交点频率及坐标值。 

2） Bode图的幅频有何变化？相频有变化吗？ 

2、 什么叫穿越频率ωc，相位裕量γ，相位交界频率ωg及幅值裕度 Kg？按计算机打印

的数据标注在相应的频率特性图上。 

3、 什么叫谐振频率ωr，谐振峰值 Mr？根据计算机打印的数据标注在相应的频率特性

图上。 

4、Nyquist图的单位园相当于 bode图上的什么线？ 

5、对于
)2)(1(

8
++

=
SSS

GK
的单位反馈系统。系统会出现谐振？你是如何用实验确定谐

振频率ωr和谐振峰值Mr。 

八、 利用MATLAB分析典型系统的频率特性(选做、自学) 

极点 

极点 

极点 零点 
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1、典型环节的频率特性测试：利用 MATLAB绘制典型环节的 Bode图与 Nyquist图，掌握典

型环节的频率特性。 

注意： 

grid on：在所画出的图形坐标中加入栅格。 

grid off：在原来加有栅格的图形坐标中取消栅格。 

hold on：使当前图形保持在屏幕上不变，同时允许在这个坐标内绘制另外一个图形。 

hold off：不再允许在同一图形坐标内绘制其他图形。 

grid on与 grid off、hold on与 hold off一般成对出现。 

（1）比例环节 10)( == KSG  

>>bode(tf(10,[1])),grid on 

>>nyquist(tf(10,[1])),grid on 

（2）积分环节
s

SG 1)( =  

>>bode(tf(1,[1,0])),grid on 

>>nyquist(tf(1,[1,0])),grid on 

（3）微分环节 sSG =)(  

>>bode(tf([1,0],1)),grid on 
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>>nyquist(tf([1,0],1)),grid on 

（4）惯性环节
S

SG
101
1)(

+
=  

>>bode(tf(1,[10,1])),grid on 

>>nyquist(tf(1,[10,1])),grid on 

 

（5）一阶段微分环节 110)( += SSG  

>> bode(tf([10,1],1)),grid on 

>> nyquist(tf([10,1],1)),grid on 
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（6）振荡环节 

①二阶系统
22

2

2
)(

nn

n

SS
SG

ωζω
ω

++
= ，绘制出ς 取不同值时的 Bode 图。其中，

nω =6rad/s，ζ 取[0.1：0.1：1]。 

%清除变量和函数 

clear 

 %频率 

wn=6; 

 %阻尼 

kosi=[0.1:0.1:1];  

%指定频率矢量 

w=logspace(-1,1,100);  

num=[wn.^2];%分子 

%for 循环 

for kos=kosi  

%分母 

den=[1 2*kos*wn wn.^2];  

%求幅值、频率、频率点矢量 

[mag,pha,w1]=bode(num,den,w); %系统波特图相应的幅值 mag、相角 pha及角频率点 w

矢量 

subplot(2,1,1); 

hold on 

semilogx(w1,mag);%幅频图 

subplot(2,1,2); 

hold on 

semilogx(w1,pha);%相频图 

end%循环结束 

subplot(2,1,1);  

%绘第一图并加上网格 

grid on  

title('Bode Plot');%标题 
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xlabel('Frequency(rad/sec)'); 

ylabel('Gain dB') 

subplot(2,1,2),  

%绘第二图并加上网格 

grid on  

xlabel('Frequency(rad/sec)'); 

ylabel('Phase deg'); 

hold off 

 

②求 nω =6rad/s，ζ 取[0.1：0.3：1.3]时的 Nyquist图 

wn=6;kosi=[0.1:0.3:1.3];num=[wn.^2]; 

n=length(kosi);%求取向量的长度 

for i=1:n 

den=[1 2*kosi(i)*wn wn.^2];  

hold on 

nyquist(num,den); 

end 

 

 

 

２ 、 分 析 开 环 系 统

)1001.0)(10025.0)(105.0(
)10167.0(500

+++
+

=
SSSS

SGK 的幅频特性和相频特性。 

(1)绘图： 

在 MATLAB的命令窗口输入下列命令，绘制系统的 Bode图与 Nyquist图。 

num=500*[0.0167 1];%分子 

den1=conv([1 0],[0.05 1]); %多项式相乘 S(0.05S+1) 

den2=conv([0.0025 1],[0.001 1]); %多项式相乘(0.0025S+1)(0.001S+1) 

den=conv(den1,den2);%分母 

Go=tf(num,den);%求传递函数 

bode(Go)  

grid on 

figure 

nyquist(Go) 

grid on 
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（2）求取相位裕度γ、幅值裕度 Kg等性能指标（要求打印图形并记录下表所要求的数据）： 

>>figure 

>>margin(Go) 

该格式用于绘制开环系统的 Bode图，并且用垂直线画出相应的交角频率，显示系统的

稳定裕度数据。 

幅值裕度(dB)  相位裕度(deg)  

频率(rad/sec)  频率(rad/sec)  

（3）求系统的增益裕量(Gm)、相位裕量(Pm)、幅值穿越频率 Wcp和相位交界频率 Wcg。 

利用 margin求系统的增益裕量(Gm)、相位裕量(Pm)、幅值穿越频率 Wcp和相位交界频

率 Wcg。 

>>[Gm,Pm,Wcg,Wcp]=margin(Go); 

>>Gm,Pm,Wcg,Wcp 

增益裕量(Gm) 相位裕量(Pm) 幅值穿越频率 Wcp 相位交界频率 Wcg 

    

3、分析
)2)(1(

8
++

=
SSS

GK 的单位反馈系统的频率特性： 

(1) 求出系统的闭环传递函数。 

clear 

num=[8]; 

den=[conv(conv([1 0],[1 1]),[1 2])]; 

[nc,dc]=cloop(num,den); 
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Gc=tf(nc,dc) 

(2)绘制闭环系统的 Bode图与 Nyquist图，并打印图形。 

>>z=[ ],p=[0  -1  -2],k=[8] 

>>[num,den]=zp2tf(z,p,k) 

>>[nn,dd]=cloop(num,den) 

>>figure ,bode(nn,dd),grid on 

>>figure,nyquist (nn,dd), grid on 

（3）直接获得谐振振幅和谐振频率的方法： 

在频率响应图中，用鼠标右击图中

的空白处，在弹出的快捷键中选择

“ Characteristics”并选中“ Peak 

Response”选项。如下图所示。 

 

接着会在频率响应图中显示出一

个蓝色圆点标志，鼠标移动到该点就显

示出系统的谐振振幅和谐振频率值。 

 

在相频特性图中，用鼠标左键点击特性曲线，会出现手形光标，在曲线上出现一个方

形黑点，并在画面上显示出该点的相位角。只要在空白处单击，就可取消黑点的显示。 

PDF 文件使用 "pdfFactory Pro" 试用版本创建 www.fineprint.cn

http://www.fineprint.cn
http://www.fineprint.cn


 

 

（4）在 MATLAB的命令窗口输入下列命令，通过调用函数求出谐振振幅 rM 、相位 rP 和谐

振频率 rω ： 

>>G=tf(nn,dd);[Mr,Pr,Wr]=mr(G) 

调用函数文件 mr.m来求谐振振幅 rM 、相位 rP 和谐振频率 rω  

function  [Mr,Pr,Wr]=mr(G) 

[mag,phase,w]=bode(G);%计算幅值、相位和频率 

mn=mag(1,:);%幅值 

pn=phase(1,:);%相位 

[M,i]=max(mn);%求最大幅值时幅值和相应的下标 i 

Mr=20*log10(M);%谐振振幅  

Pr=pn(1,i);%与谐振振幅对应的相位  

Wr=w(i,1);%谐振频率 

谐振振幅 rM  相位 rP  谐振频率 rω  

   

(5)改变系统开环增益 K，观察系统频率特性的变化规律； 

通过改变系统开环增益 K，参照前面步骤仅仅改变分子 num,其他保持不变。 

 

实验四    控制系统稳定性仿真分析 

实验四    控制系统稳定性仿真分析 

九、 实验目的 
1、运用 Routh稳定判据、Nyquist稳定判据和 Bode稳定判据来判断系统的稳定性。 

2、研究开环增益 K、时间常数 T对系统的动态性能及稳定性的影响。 

3、学会利用零极点图分析系统的稳定性。 

十、 实验设备 
序号 仪器设备名称 数量 
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1 计算机 1 

  2         MATLAB软件               1 

  3         固高球杆系统              1 

  4 打印机              1 

十一、 实验要求 
1、实验观测记录与响应曲线。 

2、观察开环增益 K、时间常数 T对系统的动态性能及稳定性的影响。 

3、要求写出判断依据以及推导过程。 

4、所做实验要求独立完成。 

十二、 实验原理 
控制系统的稳定性分析 

1、 系统稳定及最小相位系统判据 

1、对于连续时间系统，如果闭环极点全部在 S平面左半平面，则系统是稳定的。 

2、对于离散时间系统，如果系统全部极点都位于 Z平面的单位圆内，则系统是稳定的。 

3、若连续时间系统的全部零极点都位于 S左半平面；或若离散时间系统的全部零极点

都位于 Z平面单位圆内，则系统是最小相位系统。 

(二)系统稳定及最小相位系统的判别方法 

1、间接判别（工程方法） 

劳斯判据：劳斯表中第一列各值严格为正，则系统稳定，如果劳斯表第一列中出现小

于零的数值，系统不稳定。 

胡尔维茨判据：当且仅当由系统分母多项式构成的胡尔维茨矩阵为正定矩阵时，系统

稳定。 

2、直接判别 

MATLAB提供了直接求取系统所有零极点的函数，因此可以直接根据零极点的分布情况

对系统的稳定性及是否为最小相位系统进行判断。 

3、对数稳定性判据 

控制系统开环频率特性函数的极坐标图和对数频率特性图之间有如下的对应关系：极

坐标图上以原点为圆心的单位圆对应于对数频率特性图的 0分贝线；极坐标图的负实轴对应

于相频特性的
0180− 。 

对数判据之一：对于开环稳定的系统，如果系统开环对数幅频特性 )(ωL 穿过 0分贝线

时，对应的相频特性相角大于
0180− ，则闭环系统稳定；否则闭环系统不稳定。 

对数判据之二：对于开环稳定的系统，闭环系统稳定的充要条件是——在开环对数幅

频特性 )(ωL >0的所有频段内，其对数相频特性 )(ωϕ 对
0180− 线的正负穿越次数之差为 0。

如果系统在右半 S平面有 P个开环极点，则开环稳定的系统的充要条件是 )(ωL >0的所有频

段内， )(ωϕ 对
0180− 线的正负穿越次数之差为 P/2。 

4、奈氏稳定性判据 
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(1)对于开环稳定的系统，闭环系统稳定的充要条件是系统开环频率特性函数的

奈氏图不包围复平面的 )0,1( j− 点； 

(2)设开环不稳定的系统在右半 S 平面有 P 个开环极点，闭环系统稳定的充要条

件是当ω由 ∞− 变为 ∞+ 时，开环频率特性函数的奈氏图逆时针包围 )0,1( j− 点 P次。 

十三、 实验内容与步骤 

（一）分析系统
P

P

CKS
CK

S
SxSG

+
== 2)(

)()(
θ

（令 C=1）的稳定性。  

1、用劳斯判据分析系统稳定的条件（要求实验前算出系统稳定时 PK 值的范围）：系统的

特征方程是 0)( 2 =+= PKSSD 。 

由劳斯判据可知，该系统不稳定，具有两个虚根： PKiS =1 和 PKiS −=2 。 

2、根据 Nyquist 图和 Bode图利用 Nyquist 判据和

Bode判据分析系统稳定条件。 

（1）在 MATLAB命令窗口中输入 shiyan4后回车，

得到右图所示的界面。 

（2）单击 ,得到下图所示的界面。 

 

（ 3 ） 分 别 输 入 传 递 函 数

P

P

KS
KSG
+

= 2)( 分子的系数 5 与分母

的 系数(1,0,5)，然后单击 ，得到系

统的 Bode图。此时，可利用 Bode判据判断系统的稳定性。 

单击 ，得到系统的

性能指标。如下图所表示。 
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（3）在“实验四  系统的稳定性” 界面中，单

击 ,得到右图所示的界面。 

 

输入传递函数分子、分母的系数后 5

与（1，0，5），单击 ，即得系统的 Nyquist图，利用 Nyquist 判

据判断系统的稳定性。 

 

（4）在“实验四  系统的稳定性” 界面中，单击 ,得

到下图所示的界面。 

 

输入传函分子、分母的系数 5与（1，0，5）后，单击 ，即得传递函数

的零极点分布图。 

单击 ，得到传递函

数的零极点。 

 

 

 

 

 

 

 

 

 

 

（5）在“实验四  系统的稳定性” 界面中，

单击 ,得到下图所示的界面。 
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输入传递函数分子、分母的系数 5 与（1，0，5）后，单击 ，即得系

统的阶跃响应图。 

 

单击 ，得到系统

阶跃响应的性能指标。 

 

 
3、 利用 IPM Motion Studio软件分析 

（1）进入 IPM Motion Studio界

面。 

（2）选择工具栏上的“Project”

→“Open”。 

 
在弹出“Open Project”窗口，选

择“BallBeamEng.msa”,然后单击打开，得到“Technosoft IPM Motion Studio-Project 

BalllBeamEng”界面。 

        

（3）在“Technosoft IPM Motion Studio-Project BalllBeamEng”界面中，选择工

具栏上的“View” →“Project” ，弹出“Project”窗口。 
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（ 4 ） 弹 出

“ Project”窗口

后，选择工具栏上

的 ，使球杆系统

动作。然后单击工

具栏上的 ，弹出

“ Ball and Beam 

System”窗口。 

 

（5）在弹出“Ball and Beam System”窗口中，

右击，在弹出的快捷菜单中，选择“Start”。调节

Kp=5,Ki=Kd=0，观察响应曲线。 

（二）分析系统
CSKS

SKC
S
SxSG

d

d

++
+

== 2

)1(
)(
)()(

θ
（令

C=1, dK =3, 1=Kp ）的稳定性。  

1、用劳斯判据分析系统稳定的条件（要求实验前算出系统稳定时 dK 值的范围）：系统的

特征方程是 01)( 2 =++= SKSSD d 。 

2、根据 Nyquist 图和 Bode 图利用

Nyquist 判据和 Bode判据分析系统稳

定条件。 

（1）在 MATLAB 命令窗口中输入

shiyan4后回车，得到右图所示的界面。 

（2）单击 ,得到

下图所示的界面。 

 

（3）分别输入传递函数
1

1)( 2 ++
+

=
SKS
SKSG

d

d

分子的系数（3，1）与分母的系数(1,3,1)，然后
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单击 ，得到系统的 Bode图。此时，可利用 Bode判据判断系统的稳定性。 

 

 

 

单击 ，得到系统的性能指标。如下图所表示。 

 

 

 

 

 

 

 

 

（3）在“实 验四  系统的稳定

性” 界面中，单击 ,得到右图所示的界面。 

 

输入传递函数分子、分母的系数后（3，1）与（1，3，

1），单击 ，即得系统的 Nyquist图，利用

Nyquist判据判断系统的稳定性。 

 

 

 

 

（4）在“实验四  系统的稳定性” 界

面中，单击 ,得到下图所示

的界面。 
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输入传函分子、分母的系数（3，1）与（1，3，1）

后，单击 ，即得传递函数的零极点分布

图。 

 

 

单击 ，得到传递函数的零极

点。 

 

（5）在“实验四  系统的稳定性” 界面

中，单击 ,得到下图所示的界面。 

 

 

输入传递函数分子、分母的系数（3，1）与（1，3，1）后，单击 ，

即得系统的阶跃响应图。 

 

单 击

，得到

系统阶跃响应的性能指

标。 

 

3、  利用 IPM Motion 

Studio软件分析 

在弹出“Ball and Beam System”窗口中，调节 Kp=3,Ki=0，Kd=1，观察响应曲线。 

（三）分析系统

)1(

)1(
)(

2

S
KSKCKS

S
KSKCK

SG
i

dP

i
dP

+++

++
= （令 C=1， 2=PK ， 1=dK ， 05.0=iK ）

的稳定性。 
122

122
)(

)()( 23

2

23

2

+++
++=

+++
++

=
SSS

SS
KSSKKS

KSSKKSG
idP

idP  

PDF 文件使用 "pdfFactory Pro" 试用版本创建 www.fineprint.cn

http://www.fineprint.cn
http://www.fineprint.cn


1、用劳斯判据分析系统稳定的条件（要求实验前算出系统稳定时 dK 值的范围）：  

2、根据Nyquist图和Bode图利用Nyquist 判据和Bode判据分析系统稳定条件。 

（1）利用 Bode图判断系统稳定性： 

输入传递函数分子分母的系数。 

单击 ，得到系统的 Bode

图。此时，可利用 Bode判据判断系统的稳

定性。 

 

单击 ，得到系统的性能指标。 

 

（2）利用 Nyquist图判断系统的稳定性： 

输入传递函数分子、分母的系数后（2，2，1）与（1，2，2，1），

得到系统的 Nyquist图。 

 

 

 

 

（3）利用零极点图

判断系统稳定性： 

输入传函分子、分母的系数（2，2，1）与

（1，2，2，1），得到零极点分布图。 

 

 

单击 ，得到传递函数的零

极点。 

 

 

 

 

 

（4）利用系统阶跃响应判断系统稳定性： 

输入传递函数分子、分母的系数（2，2，1）与

PDF 文件使用 "pdfFactory Pro" 试用版本创建 www.fineprint.cn

http://www.fineprint.cn
http://www.fineprint.cn


（1，2，2，1），得到系统的阶跃响应图。 

 

单击 ，得到系统阶跃响应的性能指标。 

 

 3、 利用 IPM Motion Studio软件分析 

在弹出“Ball and Beam System”窗口中，调节 Kp=2,Ki=1，Kd=0.05，观察响应曲线。 

十四、 实验报告要求 
1、代数稳定判据推导过程。 

2、实验记录与响应曲线。 

3、叙述振荡环节中阻尼系数对环节的影响。 

4、结合实验遇到的问题谈谈对实验的看法，对实验现象进行分析讨论，写出本实验

的心得与体会。 

5、根据测得的系统单位阶跃响应曲线，分析开环增益 K 和时间常数 T 对系统动态特

性及稳定性的影响。 

十五、 思考题 
1、影响二阶系统动态性能的两个主要参数是什么？二阶系统在什么条件下，其瞬态

响应处于要振不振的临界状态？ 

2、在典型二阶系统中，改变增益对系统的动态性能有何影响？阻尼比对系统的动态

性能有何影响，分析三阶系统增益变化对系统稳定性的影响。 

3、系统中的小惯性环节和大惯性环节哪个对系统稳定性的影响大，为什么？ 

4、如果阶跃输入信号的幅值过大，会在实验中产生什么后果？ 

5、三阶系统中，为使系统能稳定工作，开环增益 K应适量取大还是取小？ 

八、用 Matlab程序分析系统稳定性示例(选做、自学) 

1、根据Nyquist图和Bode图利用Nyquist 判据和Bode判据分析系统稳定条件。 

（1）列出系统的闭环传递函数
210

2
210

3
210

21

)(
)(

KKSTSTTTSTTT
KKSG

++++
= 。 

（2）令 K= 21KK , 0T =1， 1T =0.1， 2T =0.51，根据闭环系统的特征多项式求其特征根

判断系统的稳定性。令 K=0.86,11.96,15,根据特征根的分布判断稳定性。 

t0=1; t0=1; t0=1; 
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t1=0.1; 

t2=0.51 

k=0.86 

t1=0.1; 

t2=0.51 

k=11.96 

t1=0.1; 

t2=0.51 

k=15 

den=[t0*t1*t2,t0*(t1+t2),t0,k];% 闭环特征多项式 

p=roots(den)%求其特征根 

（3）绘制开环系统的Nyquist图和 Bode图，分别用Nyquist 判据和Bode判据判
断系统的稳定性。 

参照下列程序代码，分别修改K=0.86,11.96,15, 绘制并打印Nyquist 图和 Bode图，

根据Nyquist 稳定判据以及Bode稳定判据判断稳定性。要求写出推导过程。 

clear 

t0=1,t1=0.1,t2=0.51,k=0.86 

num=[k] 

den=[t0*t1*t2,t0*(t1+t2),t0,0] 

G=tf(num,den) 

figure,bode(G),grid on 

figure,nyquist(G),grid on 
2、利用系统的单位阶跃响应分析稳定性 

（1）建立该系统的阶跃响应模
型。 
 

（2）分别改变开环增益 K，运

行仿真，观察系统阶跃响应曲线，

分析稳定性。 

开环增益 K1 K2 输出稳定性 

15 3 5  

11.96 4 2.99  

8 2 4  

（3）分别改变系统的时

间常数，运行仿真，观察系统

阶跃响应曲线，分析稳定性。 

 

（4）如果图形显示得不够充分，可以通过修改仿真时间来调节 x轴的范围。 

选择菜单 Simulation→Simulation parameters→出现 Simulation parameters对话框→修

改 Stop times。 
 
 

 

实验五   控制系统校正及 PID控制器仿真 
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第五章 测试与控制应用工具软件之一（Labview） 

第一节 虚拟仪器及 LabVIEW基础 
1． 虚拟仪器的概念  2.LabVIEW的发展，结构及优势  3.LabVIEW程序的基本构成 
4.LabVIEW的模板 5.LabVIEW帮助系统  6.VI编程初步 
第二节 前面板设计 
1、控件类型及属性 2、控件的操作 3、定制控件 4、前面板外观设计 
第三节 程序框图设计 
1、程序框图中的对象  2、基本数据类型  3、快速 VI   4、子 VI  5、VI的保存 
第四节 数据结构 
1、数组  2、字符串  3、簇  4、波形  5、动态数据类型  6、变量 
第五节 程序结构 
1、循环结构  2、分支结构  3、顺序结构  4、选择结构 5、事件结构  6、定时循环 
7、公式节点  8、反馈节点  9、结构连线中的常见问题 
第六节  数据的图形显示 
1、二维图形显示 2、三维图形显示 3、其他图形显示   
第七节 程序调试与运行  
1、修复程序出现的错误 2、程序调试工具 3、程序调试技巧 4、程序调试技巧 
5、程序的性能优化 
第八节  文件的输入输出 
1、文件输入输出概述 2、文本文件的输入输出 3、电子表格文件的输入输出 
4、二进制文件的输入输出 5、数据记录文件的输入输出 6、波形文件的输入输出 

第六章 Labview实例分析 

实例一：润年检测程序 

实例二  ：事件报警程序 

实例三  ：互锁按钮 

实例四  ：LabVIEW和 MATLAB的混合编程 

实例五  ：前面板外观属性的控制 

实例六  ：改变 CHART上的曲线颜色 

实例七  ：使用 ActiveX日历控件 

实例八  ：用库函数获取光标位置  

实例九：系统菜单设计 

实例十  ：阶乘 

实例十一：用户信息确认 

实例十二：公式信号发生器 

实例十三  ：事件获取菜单 

实例十四  ：阿基米德螺线的绘制 

第七章 Labview在机械工程测试技术中的应用 

一、 测试信号的产生 
1、引言 
2、模拟信号 
3、噪声信号 
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4、任意信号的产生 
5、公式节点产生的仿真信号 
6、从文件读入和直接采集测试信号 
 
二、测试信号的处理 
1、加窗 
2、滤波 
3、调制与解调 
4、信号的特征值处理 
5、波形修整、越限监测和波形操作 
 
三、测试信号的分析 
1、相关分析和卷积运算 
2、傅里叶变换 
3、谱分析 
4、谐波分析 

第八章 测试与控制系统综合实验设计与实现 

第一节  信号发生 
1、典型信号的波形分析 
2、公式信号发生器 

 
第二节 滤波 
1、滤波器 
2、相关滤波 
 
第三节 调制解调 
1、 调幅解调 
2、 调频解调 

 
第四节 相关分析 

1、 卷积与相关 
（1）程序前面板 
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（2）程序后面板 

 

其中， 是一个子 VI，由于 LabVIEW中自相关函数和互相关函数计算公式都少

了
iN −

1
，因此就设计一个修正子程序 对自相关和互相关计算结果进行修正。 
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（3）程序设计步骤： 

①基本函数发生器，选择 All Function→Analyze→Waveform Generation→Basic 
Function Generator，可以产生正弦波、三角波、锯齿波、方波四种信号。 

②卷积函数 Convolution的使用，选择 All Function→Analyze→Signal Processing→

Time Domain-Convolution。 

③反卷积函数 Deconvolution的使用，选择 All Function→Analyze→Signal Processing

→Time Domain- Deconvolution。 

④自相关函数 AutoCorrelation 的使用，选择 All Function→ Analyze→ Signal 

Processing→Time Domain-Convolution。 

⑤互相关函数 AutoCorrelation 的使用，选择 All Function→ Analyze→ Signal 

Processing→Time Domain- CrossCorrelation。 

2、相关法测相位差 
 
3、相关法测周期信号 
 
第五节 谱分析 
1、 典型信号的谱分析 
2、 典型信号的 FFT谱分析 

（1）程序前面板 
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（2）程序后面板 

 
（3）程序设计步骤： 

①典型信号的产生，与前面的典型信号的发生相同。 

②功率谱分析函数 FFT Power Spectrum，选择 All Function→Analyze→Waveform 

Measurements→FFT Power Spectrum。 

③功率谱密度分析函数 FFT Power Spectral Density，选择 All Function→Analyze→

Waveform Measurements→FFT Power Spectral Density。 

④傅里叶变换频谱分析函数（计算结果为幅度和相位）FFT Spectrum (Mag-Phase)，选
择 All Function→Analyze→Waveform Measurements→FFT Spectrum (Mag-Phase)。 

⑤傅里叶变换频谱分析函数（计算结果为实部和虚部）FFT Spectrum (Real-Im)，选
择 All Function→Analyze→Waveform Measurements→FFT Spectrum (Real-Im)。 

 
第六节 振动实验台模拟分析 
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1、 振动实验台 
2、 电桥电路 
第七节 一阶、二阶系统的时域分析 
1、 一阶系统的时域分析 
2、 二阶系统的时域分析 
第八节 一阶、二阶系统的频域分析 
1、一阶系统的频域分析 
2、二阶系统的频域分析 
第九节 液压传动虚拟实验 
1、 液压泵性能实验 
2、 溢流阀性能实验 
3、 调速回路性能实验 
4、 液压基本回路实验 
第十节 测试与控制综合实验 

1、数控机床工作台的位置检测与控制 
2、基于声卡的数据采集分析系统 
3、液压泵的智能检测与控制 
4、空气压缩机组的智能检测与控制 
5、球杆系统的 PID控制及滤波设计 
6、机械手的模糊控制及多传感器数据融合设计 
7、倒立摆的模糊控制仿真及多传感器数据融合设计 

 

第九章 机械测试与控制系统工程实例分析 

1、发电机组故障诊断 
2、锅炉供热自动控制系统 
3、电网谐波测试 
4、输油泵状态监测 
5、液压系统测试 
6、甘蔗收割机的数据采集分析系统 
7、甘蔗煮糖的数据采集分析系统 
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